Pi Control - Update 1.3.3

Pi Control 1.3

Ab sofort ist Pi Control 1.3 für deinen Raspberry Pi verfügbar. Die aktuelle Version gibt es wie immer in deinem Pi Control als Update, oder hier als Download.

Pi Control 1.3

Neuerungen in Pi Control 1.3

  • Neu: CPU-Auslastung Statistik
  • Neu: RAM-Auslastung Statistik
  • Neu: CPU-Auslastung
  • Statistiken ein-, ausblenden und zurücksetzen
  • Sicherheit erhöht
  • Installation erweitert
  • Bugfixes

Android App

Und nicht vergessen, die Android App aus dem Google Play Store herunterladen, bewerten und fleißig nutzen! 🙂

Feedback ist Gold wert – deshalb freue ich mich wieder über jeden Kommentar, jede Kritik und natürlich jedes Lob. Viel Spaß mit dem Pi Control!

36 Gedanken zu „Pi Control 1.3

  1. Hallo, das Programm ist nett und macht nen guten Eindruck.
    Hier hatte soweit alles geklappt, bis auf das Motion – Plugin.

    Ich nutze eine IPCam, diese ist passwort geschützt.
    In den Einstellungen beim Motion-Plugin kann man aber nur den Port ändern und eine Passwortabfrage kam nicht …

    Das nur so am Rande – ansonsten fand ich das schon Interessant – ich werde mich sicher noch am Quellcode austoben zum lernen ;).

    Viel Spaß und Erfolg weiterhin + schönen Dank für Deine Mühe !!!

    1. Hallo Pelzi,
      bitte entschuldige die späte Antwort. Hatte in den letzten Tagen viel zu tun.
      Ich werde versuchen, diesbezüglich ein Update bereitzustellen.

      Gruß
      Willy

  2. Hallo Willy,

    Dies ist ein wirklich sehr schönes und schlankes Programm. Allerdings kann ich bei dem FritzBox Plugin nicht auf Version 6 umschalten. Er springt immer wieder auf Version 5 zurück. Ebenfalls kann ich die Adresse der Box nicht abändern. Wo liegt da der Fehler?

    Danke für deine Bemühungen 🙂

  3. Hey! Wollte das PiControl auch mal ausprobieren, bekomme aber jedoch eine Fehlermeldung, wenn ich den wget-Befehl eingebe:

    ————–
    pi@raspberrypi ~ $ sudo wget http://picontrol.willy-tech.de/pi
    –2015-04-20 22:45:56– http://picontrol.willy-tech.de/pi
    Resolving picontrol.willy-tech.de (picontrol.willy-tech.de)… 31.220.43.142
    Connecting to picontrol.willy-tech.de (picontrol.willy-tech.de)|31.220.43.142|:80… connected.
    HTTP request sent, awaiting response… 404 Not Found
    2015-04-20 22:45:56 ERROR 404: Not Found.
    ————–

    Sprich: ich kanns nicht mal runterladen… Eine Idee?

    MfG Tim

    1. Hallo Tim,
      du hast den Befehl falsch kopiert bzw. etwas vergessen. Der komplette wget-Befehl ist:
      wget http://picontrol.willy-tech.de/picontrol_installer

      Gruß
      Willy

  4. hi,
    this look great, but gplay says there is no compatible device so I can’t try it. if asus hd7 (jb4.3) and lg g2 (factory 4.4.2) aren’t compatible then please explain in app description which couple of devices are. but would be better to set the compatible devices switch to „all“ on play store 🙂 danke.

  5. Hallo Willy,

    tolles System!

    Wir betreiben den PI aber hinter einem Proxy, wie verhält es sich da mit den Downloads und co, weil scheinbar kann er nicht die Plugins laden wenn ich so hinterm Proxy bin – oder liege ich falsch?

  6. Hallo,

    coole Anwendung! Hat mir bisher sehr geholfen!
    Eine Frage könnten Sie vielleicht ein WebFTP Feature mit einbauen? Würde mich sehr freuen!

    MFG Eric

      1. Hallo Willy,

        nachdem mit dem Luftdruck-Plugin alles funktioniert hat, habe ich mir mal das Plugin für die GPIO´s runtergeladen. Leider hat das nicht funktioniert. Folgende Fehlermeldung erschien: „Download fehlgeschlagen.
        Das Pluginarchiv wurde nicht vollständig heruntergeladen. Bitte versuche es erneut. Sollte der Fehler weiterhin auftreten, schreibe mir unter Kontakt, sodass ich dir möglichst schnell weiterhelfen kann.“

        Ich habe daraufhin mal das Plugin-Verzeichnis kontrolliert und gesehen das dort eine Datei „Plugin.zip“ existiert. Ich habe das Archiv dann unter Windows mal geöffnet und festgestellt, dass das offensichtlich das richtige Plugin ist doch leider kann es nicht weiter installiert werden. Kann ich da was machen?

        mfg
        Heinz-Rolf

        1. Hallo Heinz-Rolf,
          vielen Dank für die Info. Mir ist da vermutlich gestern ein kleiner Fehler unterlaufen, als ich das „Luftdruck“-Plugin aktualisiert habe.
          Sollte jetzt wieder funktionieren.

          Gruß
          Willy

          1. Das hat jetzt funktioniert, allerdings habe ich nach der Installation keinerlei Funktionen. Beispiel:
            Ich lege GPIO 17 an;
            Meldung erscheint Status wird aber nicht geändert. Kontrolle in der Konsole ergibt: GPIO 17 ist belegt.
            In der Übersicht kann ich den Port aber nicht ein bzw. ausschalten. Keine Reaktion. Von der Konsole funktionert das aber. Status wird aber bei erneutem laden der Seite nicht geändert.

            Sorry, wenn ich nerve.

          2. Füge bitte noch den Benutzer www-data der Gruppe gpio hinzu:
            sudo usermod -aG gpio www-data
            Anschließend muss der Raspberry Pi eventuell neu gestartet werden.
            Nein, nerven tust du nicht. 🙂

            Gruß
            Willy

  7. Das funktionier jetzt. Aber wird da wirklich der Port ein bzw. aus geschaltet.
    Test:
    mit PIC port 17 gesetzt, anschliessend eingeschaltet, Anzeige alles OK.
    Testled am Raspi bleibt aber aus und eine Abfrage über den Status in der Konsole ergibt GPIO 17 = 0.

    1. Wenn im Plugin GPIO 17 (Port 11) eingeschaltet ist und anschließend die Seite neu geladen wird, bleibt der GPIO entsprechend an?
      Welche Ordner werden bei Eingabe des Befehls angezeigt?
      ls /sys/class/gpio/

      Gruß
      Willy

      1. Plugin:
        1. Port eingeschaltet Anzeige = grün und 1
        2. Seite neu geladen
        3. Port ausgeschaltet Anzeige rot und 0

        ls /sys/class/gpio/

        export gpio17 gpiochip0 unexport

        1. Wie es scheint, hat der Webserver „www-data“ immer noch keine Berechtigung den GPIO zu schalten. Hast du den Raspberry Pi schon neugestartet?

          Gruß
          Willy

          1. Nach Neustart das gleiche.
            Per Plugin setzen und löschen ok. Kontrolle über Konsole Ok.
            Per Plugin einschalten keine Reaktion und nach Neuladen der Seite wieder ausgeschaltet.

          2. Wenn ich auf den Aktualisierunsbutton klicke wird der Zustand auch wieder auf rot und 0 gesetzt.

          3. Ich glaube ich habe das Problem gefunden:
            ich muss **zweimal** den GPIO „anlegen“ obwohl beim erstenmal schon der Status geändert wurde. Danach kann ich den Port einwandfrei schalten. Mache ich das anlegen nur einmal passiert das was ich vorhin schon beschrieben habe.

          4. Das ist natürlich merkwürdig. Konnte jetzt leider auch nicht mehr dazu finden. Sollte sich dennoch was ergeben, werde ich nochmal bescheid geben. Wenn es so erstmal funktioniert, ist das ja schon mal gut.

            Gruß
            Willy

  8. Noch ein Nachtrag:
    anlegen und löschen reagiert auf entsprechende Eingabe von der Konsole (export und unexport per GPIO)

  9. Bin dafür das der Code bei GitHub landet und man als Community dran weiter entwickelt… hätte schon ein Plugin und eine Erweiterung für die Graphen …

  10. Hallo Willy,
    ich hab Pi Control tadelos installieren können und finde es super. Ich frage mich ob es eine Liste von geplanten Änderungen / Plugins gibt? Würde mich interessieren…

    Ich habe aber auch ein kleines Problem:
    Ich habe nach der Installation das Passwort für den ssh Zugang geändert. Nun kann ich nicht mehr über PiC „neu starten“ oder „herunterfahren“. Kann man den nachträglich noch ändern?

    Oder muss ich neu installieren?

    Viele Grüße,
    Matthias

    1. Hallo Matthias,
      bitte entschuldige die späte Antwort. Habe im Moment viel zu tun.
      Leider ist ein ändern des SSH-Zugang nicht so einfach im Pi Control möglich.
      Im Webserververzeichnis, wo der Pi Control-Ordern zu finden sein sollte, sollte es ebenfalls noch einen Ordern mit dem Namen „install_xyz…“ geben. Diesen bitte in „install“ umbenennen und im Browser auf das Pi Control gehen. Anschließend kann die Installation mit neuen Benutzernamen und Passwort wiederholt werden. Einstellungen im Pi Control bleiben davon unberührt.

      Gruß Willy

    1. Hallo Sven,
      momentan ist nur eine SSH-Anmeldung mit Benutzername und Passwort möglich. SSH-Keys werden für die Anmeldung noch nicht unterstützt.

      Gruß
      Willy

  11. Guten Tag Herr Fritsch,

    wir nutzen Ihr Tool unter Banana Pi und es funktioniert dort auch sehr gut. Momentan schalten wir nur LEDs damit (für eine Modeleisenbahn) und es wäre nett wenn wann es möglich wäre den GPIO-Port zu beschriften (Feld zwischen GPIO und IN/OUT). Vielleicht
    könnten Sie uns einen Tipp geben wo man das in den Scripten einplfegen könnte.

    Vielne Dank

    Franz Xaver + Felix Schweiger

  12. Sehr geehrter Herr Fritsche,

    nachdem ich ihr Tool nun seit einiger Zeit teste habe ich einen Vorschlag für die Konfiguration: Bei der Anzeige der Graphen für meine eth0 Verbindung ist mir aufgefallen, dass der Graph bei 8GB Traffic auf 4GB zurückspringt, und dann wieder von vorne zu zählen beginnt. Wäre es möglich einzustellen, dass gewisse Zeiträume (bspw. 0:00 – 24:00 Uhr) überwacht werden und erst danach zurückgesetzt wird? So ist die Graphik leider schlecht zu lesen.

    Mit freundlichen Grüßen

    Strainer

    1. Hallo Strainer,
      leider ist dies noch ein Bug in der aktuellen Pi Control-Version. Dieser ist mir bereits bekannt und auch schon im nächsten Update behoben.
      Das besagte Update wird sehr wahrscheinlich noch diese Woche erscheinen.

      Gruß
      Willy

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.